Tomcat启动错误unsupported major.minor version 52.0解决方法

今天在部署项目时发现服务器上的tomcat出现了unsupported major.minor version 52.0错误,有点诧异,明明本地项目运行好好的,怎么到了服务器就不行了呢。如图

Tomcat启动错误unsupported major.minor version 52.0解决方法

后来想一想,应该是版本的问题,服务器使用的jre是1.7版本,而本地环境中有多个jre,而项目中用到的就是1.8的版本。低版本不能兼容高版本,所以将项目中的编译方式改为1.7版本jre,问题解决

Tomcat启动错误unsupported major.minor version 52.0解决方法

Tomcat启动错误unsupported major.minor version 52.0解决方法



未经允许请勿转载:程序喵 » Tomcat启动错误unsupported major.minor version 52.0解决方法

点  赞 (0) 打  赏
分享到: